Upgrade to Symfony 6

Edit on GitHub

Spryker primarily supports Symfony 6 that was released in December 2022. Backward compatibility remains for all three major Symfony versions, but support for Symfony 4 was partially dropped in October 2022.

Avoid old Symfony versions

Although Spryker still supports older versions of Symfony, avoid installing them. Installing older versions of Symfony may cause conflicts with other packages that may have different requirements. Always try to keep your dependencies updated.

Main changes in Symfony 6

Symfony 6 has a new cycle of innovations. When it starts, one cycle lasts two years, on a modernized codebase that has been cleaned up from the dead weight of the past. The major change included in Symfony 6 is PHP 8.0 being the minimum required version of PHP. The code of Symfony 6 has been updated. You can take advantage of all the new features in PHP. For example, the code includes PHP 8 attributes, more expressive and rigorous type declarations, and more.

Read more at CHANGELOG-6.0.

Upgrade Symfony to version 6

To make your project compatible with Symfony 6, update the Symfony module and all modules that use it:

composer require spryker/symfony:"^3.11.0"

If you can’t install the required version, run the following command to see what else you need to update:

composer why-not spryker/symfony:3.11.0

This gives you a list of modules that require the latest spryker/symfony module and that need to be updated as well.